Hyperviseur vSphere ESXi

Dans ce Tutoriel, le but va être la mise en place de différents VLAN qui auront chacun un sous-réseau
différent des autres. Trois hyperviseurs ESXi seront installés et paramétrés pour pouvoir
communiquer dans le VLAN 213 (Hyperviseurs).
Pour cela, nous disposons du routeur B et du switch LAB_B. Nous devons donc paramétrer ces
interfaces pour pouvoir les interconnecter et ainsi rendre la communication entre les différentes
interfaces possible.
Le principal objectif sera d’assurer la redondance des tâches et donc la continuité de service.
Si un hyperviseur ne répond plus, les machines virtuelles qu’ils hébergent doivent pouvoir être
lancées automatiquement sur un autre hyperviseur opérationnel (Fonctionnalité HA) ou migrés à
chaud (vMotion).

Prérequis :

Un routeur CISCO.
Un Switch CISCO.
La licence vSphere.
Graver les logiciel vSphere sur des DVD d'installations.
Une clé USB.
Un càble série pour configurer switch et routeur.

Infrastructure réseau mise en place :

Shéma infrastructure Hyperviseur vSphere ESXi

 

Étape 1 - Configuration du routeur :

enable
configure terminal
interface GigabitEthernet0/0
no ip address
duplex autospeed auto
exit
interface GigabitEthernet0/0.210
encapsulation dot1Q 210
ip address 192.168.210.254 255.255.255.0
exit
interface GigabitEthernet0/0.211
encapsulation dot1Q 211
ip address 192.168.211.254 255.255.255.0
exit
interface GigabitEthernet0/0.202
encapsulation dot1Q 202
ip address 192.168.202.150 255.255.255.0
exit
interface GigabitEthernet0/0.213
encapsulation dot1Q 213
ip address 192.168.213.254 255.255.255.0
exit
interface GigabitEthernet0/0.214
encapsulation dot1Q 214
ip address 192.168.214.254 255.255.255.0
exit
exit
copy running-config startup-config

 

Étape 2 - Configuration du switch :

enable
configure terminal
vlan 210
name infra_reseau
exit
vlan 211
name serveurs
exit
vlan 202
name stockage
exit
vlan 213
name hyperviseurs
exit
vlan 214
name client
exit
interface GigabitEthernet0/1
switchport mode trunk
no shutdown
exit
interface Vlan210
ip address 192.168.210.250 255.255.255.0
exit
interface range FastEthernet0/1-4
switchport access vlan 210
exit
interface range FastEthernet0/5-8
switchport access vlan 211
exit
interface range FastEthernet0/9-12
switchport access vlan 202
exit
interface range FastEthernet0/13-18
switchport access vlan 213
exit
interface range FastEthernet0/19-24
switchport access vlan 214
exit
exit
copy running-config starting-config

 

Étape 3 - Installation des hyperviseur ESXI :

Mettre le cd d'installation de l'hyperviseur et:

Choisir "Enter" pour installer ESXI.
Appuyer sur F11 pour accepter et continuer ( "Accept and continue" ).
Choisir "Enter" pour choisir la partition.
Une fois votre partition sélectionner faire "Enter".
Choisir la langue : French et "Enter" pour continuer.
Entrer le mot de passe root : "administrateur" (enfin mettez celui de votre choix).
Appuyer sur F11 pour installer.
Appuyer sur « Enter » pour relancer le serveur.

 

Étape 4 - Paramétrage des serveurs ESXI :

Une fois sur la page de votre ESXI.
Appuyer sur F2 pour configure ESXI.
Entrer le mot de passe défini : administrateur.
Dans, "Configure Management network".
"IP Configuration".
Il faut cocher "Set static IP address".
Et paramétrer en fonction de l’adresse IP, le masque de sous-réseau et la passerelle.

Dans le cas de ce tuto on met:
IP Address: 192.168.213.12
Subnet Mask:255.255.255.0
Default Getway:192.168.213.254

Aller dans "DNS Configuration" et mettre le "Hostname".
Appuyer sur la touche "Echap", et valider les changements par "Y".

 

Étape 5 - Modification des paramètres au niveau du switch :

Les paquets envoyés par l’hyperviseur dans le réseau de management ne sont pas taggués. Il faut
donc indiquer au switch quel est le Vlan natif. Ainsi le switch considérera les paquets non taggués
comme appartenant au Vlan 213.

enable
configure terminal
interface range FastEthernet0/13-18
switchport mode trunk
switchport trunk native vlan 213
no shutdown

 

Étape 6 - Mise en place de la cible iSCSI sur le NAS :

 

Afin de bénéficier de toutes les fonctionnalités de l’infrastructure Vmware (vMotion, Haute
disponibilité, etc) il est nécessaire de disposer d’un espace de stockage partagé entre les différents
hôtes ESXi.
Pour commencer on modifie l’entrée Ethernet 2 pour lui affecter l’adresse IP.

Dans notre cas:
Adresse IP:192.168.202.150
Masque de sous-réseau:255.255.255.0

On ajoute une cible réseau iSCSI.
Sélectionner "Configuration".
On choisit de créer une cible iSCSCI avec un LUN.
On nomme notre cible iSCSI.
Nom cible "no-impact".
Alias de la cible "no-impact".
Cliquer sur "SUIVANT".

On ne paramètre pas d’authentification CHAP.
Cliquer sur "SUIVANT".

On lui dédie une capacité après avoir coché la case "Sous-dimensionnement", on lui affecte un
volume ("emplacement du LUN").
Capacité 1To.
Cliquer sur "SUIVANT".
Finissez la configuration par "Valider".

 

Étape 7 - Configuration de l'initiateur iSCSI et montage du LUN sur l'hyperviseur :

Ensuite dans "Mise en réseau", on ajoute un adaptateur de mise en réseau, on choisit donc.
d’utiliser le "vSwitch0".

On nomme le nouveau port en "iSCSI" et on lui affecte le vlan 202 qui est celui du stockage.
Cliquer sur "Suivant".

On affecte la bonne adresse IP : 192.168.202.152 (150 pour le routeur et 151 pour le port Ethernet 2).

Ensuite on retourne sur l’initiateur iSCSI créé précédemment. A l’aide d’un clic droit, on modifie les
propriétés pour ajouter le port réseau qui vient d’être créé : iSCSI(vSwitch0).

Toujours dans les propriétés, dans l’onglet "Découverte statique" on ajoute l’emplacement serveur.
iSCSI : 192.168.202.151

Ensuite on paramètre le disque LUN dans « Configuration », « Stockage », on lui affecte donc le.
disque paramétré à 1To.

Ensuite on choisit la version du système de fichiers (ici : VMFS-5).
Cliquer sur "Suivant".

On obtient donc une fenêtre de résumé des opérations qui vont être faites.
Cliquer sur "Suivant".

 

Étape 8 - Installation du derveur de gestion "vCenter" :

On prend le package d’installation du vCenter.
Dans vSphere Client , on cherche donc le fichier précédent et on appuie sur "Next".
Continuer par "Next".

On affecte un nom à notre machine virtuelle "test123".
Continuer par "Next".

On garde donc tous les paramètres par défaut et on attend que la machine soit créée.
Après la création de la machine, on obtient l’écran de connexion.

On se connecte en tant que "root" avec comme mot de passe (par défaut) "vmware".
que l’on a changé par ce que vous souhaitez.

Ensuite on entre la ligne de commande "/opt/vmware/share/vami/vami_config_net" qui va permettre de
modifier les paramètres pour l’interface Web.

On affecte l’adresse IP 192.168.213.10 avec comme masque 255.255.255.0
En nom d’hôte : vcenter-no-impact.

Une fois que les configurations IP sont faites, on tape 1 pour sauvegarder.

Dans le navigateur Internet, on tape l’adresse IP de la machine virtuelle suivi du port utilisé :
192.168.213.10:5480

On s’identifie avec "root" et "vmware" (ou le mot de passe que vous avez choisis).

Ensuite, on accepte les conditions générales d’utilisation du produit.
Choisir de configurer grâce aux paramètres par défaut : (tout se fait donc automatiquement).
Continuer par "Next".

Ensuite si tout ce passe bien vous aurez du vert partout.
Finissez la configuration par "Close".

On observe donc que les services se sont lancés et sont en cours d’exécution.

Une fois l’installation terminée, on peut se connecter au vCenter en utilisant vSphere Client.
On va donc passer au paramétrage du cluster d’hyperviseurs ESX.

 

Étape 9 - Paramétrage du cluster ESX :

Une fois connecté, on crée un centre de données qui contiendra un ou plusieurs cluster(s).
Faire un clic droit sur le centre de données et créer un "nouveau cluster"
On laisse tout par défaut sauf le nom que l’on définit.
Pour finir, valider chaque étape sans activer EVC.

Une fois le cluster créé, on fait un clic droit pour créer un "nouvel hôte".
Cette manipulation doit être faite pour chaque hyperviseur ESX (trois fois dans notre cas).
Il suffit de donner l’adresse IP au niveau du champ "hôte".
Pour pouvoir donner l’accès à l’hyperviseur il faut entrer "root" et le mot de passe de l’ESX
"administrateur".
Cliquer sur "Suivant"

Ensuite, il faut valider le certificat.
Renouveler cette manipulation autant de fois que nécessaire.

ATTENTION: Ne pas monter manuellement le stockage ou formater la partition !!!

 

Conclusion :

A travers les différentes étapes qui ont été suivies, nous pouvons assurer la disponibilité des
machines virtuelles des hyperviseurs grâce au système de migration à chaud. L’utilisateur pourra
donc continuer à utiliser les différents services qui lui sont mis à disposition.